爱,不是简单的一个字,是相知相惜,是宽容理解。爱到深处,一个爱字又怎能饱含那份真情。

交换机部分配置命令

技术文档 4463浏览 0评论

一、交换机五种模式:

Switch>                         (用户模式)
Switch#                         (特权模式)
Switch(config)#                (全局配置模式)
Switch(config-if)#            (接口模式)
Switch(config-line)#          (线模式)

二、交换机模式切换
Switch>enable               //切换到特权模式
Switch#config terminal     //切换到全局配置模式
Switch#interface f0/1   //进入接口f0/1
Switch(config)#interface vlan 1    //进入vlan-id为1的vlan配置中
Switch(config-if)#ip address 192.168.1.1 255.255.255.0    //对vlan-id为1的vlan设置IP地址和子网掩码
Switch(config-if)#no shutdown     //激活vlan-id为1的vlan

三、设置交换机的密码
1、用户到特权的密码
Switch(config)#enable password 123 (优先级低)
Switch(config)#enable secret 123 (优先级高)
//如果两个都设置,则456生效。两者的区别是:enable password在配置项中是明文显示,而enable secret在配置项中是密文显示。

2、控制台console密码设置
Switch(config)#line con 0   //进入CON线路的配置中
Switch(config-line)#login   //在该线路上启用口令校验功能
Switch(config-line)#password console123  //设置console密码为console123

3、启用telnet密码
Switch(config)#line vty 0 15  //最多有0~15个人可以telnet访问switch,合计16人
Switch(config-line)#login    //在线路上启用口令校验功能
Switch(config-line)#password telnet123   //设置telnet密码为telnet123
注:要真正生效telnet还要设置特权密码

四、线模式中常用的命令:(交换机或者路由器)
1、access-class:在特定线路上运用已定义的访问控制列表。完整格式为access-class X in(其中x为访问控制列表号access-list number)
举例:
Switch(config)#access-list 1 permit 202.112.77.0 0.0.0.255    //设置访问控制列表1,允许202.117.77.0/32的主机访问
Switch(config)#line vty 0 4    //最多有0~4人可以telnet访问switch,合计5人
Switch(config-line)#login
Switch(config-line)#password 686135    //设置telnet密码为686135
Switch(config-line)#access-class 1 in  //在vty线路上运用访问控制列表1
Switch(config-line)#exit
Switch(config)#line con 0         //进入console线路即控制台端口线的配置模式
Switch(config-line)#login
Switch(config-line)#password 686135
Switch(config-line)#access-class 1 in  //在line线路上运用访问控制列表1

PS1:注意区别access-group,access-group用于控制接口,即在接口上运用访问控制列表。如下例:
Switch(config)#interface f0/0     //进入接口f0/0配置子模式

Switch(config-if)#ip access-group 1 in   //将访问控制列表1应用到接口f0/0的out方向上。其中1是ACL号,和相应的ACL进行关联。Out是对路由器该接口上哪个方向的包进行过滤,可以有in和out两种选择,默认为out方向。
注意:这里的in/out都是站在路由器或三层模块(后简称R)上看的,in表示从该接口进入R的包,out表示从该接口出去的包。

PS2:通常有以下4种线路类型:
线路类型全称                     说明
CON      Console,控制台端口线    用于配置目的登录到路由器
AUX      辅助端口线               通过Modem连接,完成配置
TTY      异步线(Asynchronous)     仅用于访问服务器(RSA)的异步接口
VTY      虚拟终端线               用于通过路由器的同步端口(如以太网口、串行口)接入的Telnet、LAT等连接
注:Cisco路由器,对各种类型的线路进行了统一的编号。其中,CON:line=0;tty n:line=n;AUX:line=last_tty+1;vty m:line=last_tty+2+m。

2、Transport input(或output) none
1)要定义连接路由器特定线的协议,用transport input线配置命令。
Transport input {all|lat|mop|nasi|none|pad|rlogin|telnet|v120}
语法说明:
all 选择所有协议;
lat 选择Digital LAT协议,这是最常用于将路由器连接Digital主机的协议;
mop 选择Maintenance Operation Protocol (MOP);
nasi 选择NetWare Access Servers Interface (NASI)作为输出传输协议;
none 线上不允许任何协议选择。系统通常假设不认识的命令为主机名。如果协议设置为none,则系统不再作这个假设,不认识的命令不能建立连接;
pad 选择X.3PAD,最常用于将路由器连接X.25主机;
 rlogin 对TCP连接选择UNIX rlogin协议。vlogin设置是Telnet的特例。如果rlogin特定主机失败,则跟踪失败,后续连接请求改用Telnet;
telnet 选择TCP/IP Telnet协议,使用户可以在一个站点建立与另一站点登录服务器的TCP连接。
v120 对ISDN连接中的输出异步数据选择V.120协议。

缺省:线上禁止选择任何协议(none)
    命令方式:线配置
    使用指南:这个命令最初在Cisco IOS Release 10.0中出现。
    关键字all 、lat、pad和v120最初出现在Cisco IOS Release 11.1中。选项none在Cisco IOS Release 11.1中开始变成缺省值。在Cisco IOS Release 11.1之前,缺省为all。
    警告:Cisco路由器缺省不接收异部端口(TTY线)的输入网络连接。要先指定输入通信协议或指定transport input all之后才能接收输入连接。例如,如果把路由器作为终端服务器,建立与路由器或其它设备的控制台端口连接,则不能用Telnet连接这些设备,会出现消息"Connection Refused"。这个功能是从Cisco IOS Release 11.1开始的。在Cisco IOS Release 11.1之前,缺省为transport input all。如果从Cisco IOS 11.0以前升级到Cisco IOS Release 11.1以后,则要增加transport input {protocol all}命令,否则会锁住路由器。
    可以指定一个协议、多个协议、全部协议或无协议。要指定多个协议,输入每个协议的关键字,用空格分开。
    这个命令可以在不同类型用户之间区分资源,也可以保证只有特定主机能访问某个端口。使用两步协议翻译时,transport input命令可以准确地控制哪个协议能翻译成其它协议。
    除了让transport input命令生成访问表外,还可以定义每个协议的访问表。transport input命令中的设置会覆盖transport preferred命令所作的设置。
举例:
    下例对VTY 0到32将输入协议设置为Telnet:
line vty 0 32
transport input telnet

2)要确定线路输出连接可用的协议,用transport output线配置命令。
  transport output {all | lat | mop | nasi | none | pad | rlogin | telnet | v120}
3、exec-timeout:用来设置退出特权用户配置模式超时时间。“exec-timeout”命令的完整形式为:exec-timeout x x (也就是exec-timeout 分秒),默认为6分钟。注:如果你在此输入“exec-timeout 0 0”则表示你将永远与路由器保持联接,除非你自己logout(或quit)。如果不输入此命令,当你进入路由器没有输入任何内容时,10分钟后将被交换机(或路由器)自动踢出。

举例:
exec-timeout 5 0     //5分钟0秒后后自动退出特权用户模式

五、交换机命名hostname BENETSW01
Switch(config)#hostname BENETSW01   //使用hostname命名交换机的名字

六、show命令集

Switch#show version               //显示IOS版本信息
Switch#show int vlan 1 brief         //简单的显示VLAN1的信息
Switch#show running-config         //显示正在运行的配置文件
Switch#show startup-config          //显示己经保存的配置文件
Switch#show mac-address-table       //显示MAC地址表
Switch#show mac-address-table       //显示MAC地址表更新的间隔,默认为5分钟
Switch#show neighbor detail          //显示邻居详细信息
Switch#show traffic                  //显示CDP流量

七、设置交换机的网关和DNS名称服务器的IP地址
Switch(config)#ip default-gateway 192.168.10.8       //交换机的网关设置为192.168.10.8
Switch(config)#ip domain -name server  202.106.0.20  //设置DNS名称服务器地址
Switch(config)#no ip domain-lookup            //交换机名称服务器的域名查询
八、创建、删除、查看VLAN
Switch#vlan database    //进入vlan数据库配置模式
Switch(vlan)#vlan 2     //创建VLAN2命名为vlan0002,也可以使用vlan2 name sales
VLAN 2 added:
Name: VLAN0002
Switch(vlan)#exit         //退出时应用生效
Swith(vlan)#no vlan 2     //删除vlan2

Switch(config)#interface f0/1
Switch(config-if)#switchport access vlan 2     //将端口加入vlan 2中
Switch(config-if)#no switchport access vlan 2   //将端口从vlan2中删除

Switch(config)#interface range f0/1-10   // 进行F0/1到10端口范围
Switch(config-if-range)#switchport access vlan 2 //将f0/1到f0/10之间的所有端口加入vlan 2

Switch#show vlan brief                //查看所有VLAN的摘要信息
Switch#show vlan id vlan-id        //查看指定VLAN的信息

九、开启并查看trunk端
Switch(config)#interface f0/24
Switch(config-if)#switch mode trunk    //将f0/24端口设置为trunk

Switch#show interface  f0/24  switchport  //查看f0/24的接口状态

十、从Trunk中添加、删除Vlan
Switch (config-if )#switchport trunk allowed vlan remove 3   //从trunk端口删除v lan3通过
Switch (config-if)#switchport trunk allowed vlan add  3     //从trunk端口添加vlan3通过
Switch #show interface interface-id switchport           //检查中继端口允许VLAN的列表

转载请注明:自由的风 » 交换机部分配置命令

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址